Partial GMail Outage

Major incident Google Workspace
2022-07-22 11:05 BST · 23 hours, 13 minutes

Updates

Resolved

Emails that were delayed all now seem to have been delivered. Google Support have said the incident is now resolved. Please let us know if you are still having any issues.

July 23, 2022 · 10:19 BST
Issue

Gmail for some customers is struggling with incorrect rate limiting. This means that some emails are being delayed and some are not arriving in a timely fashion. This is known Google partial outage and is being addressed by Google Support as a P1 event. Further updates to follow. If you have questions, please do NOT email us, please call us instead - 01273 359 133 - thanks

July 22, 2022 · 11:07 BST

← Back