Temporary internet outages

Major incident ADSL/FTTC Internet Connections
2022-02-11 12:21 BST · 15 minutes, 44 seconds

Updates

Resolved

Updated in new outage report.

February 11, 2022 · 12:37 BST
Issue

We are aware of widespread internet outages. Our network engineers are investigating the issue as a priority and will provide an update as soon as possible.

February 11, 2022 · 12:23 BST

← Back