Outbound calling

Minor incident Telephony
2021-07-27 12:00 BST · 5 hours, 19 minutes, 52 seconds

Updates

Resolved

Issue appears to have been resolved by upstream provider earlier this afternoon. Incident kept open until end of day in case there were any remaining or recurring issues.

July 27, 2021 · 17:19 BST
Investigating

Partial Outage: Ongoing issues with making outbound calls. Some failing, some of poor call quality. Updates to follow.

July 27, 2021 · 12:24 BST

← Back