Partial phone outage

Major incident Telephony
2021-06-08 12:32 BST · 15 minutes, 18 seconds

Updates

Resolved

This has now been resolved. Post mortem to follow.

June 8, 2021 · 12:47 BST
Issue

There is a currently a phone outage, affecting some phones but not others. Updates will be posted as they come.

June 8, 2021 · 12:33 BST

← Back