Telephony down

Major incident Telephony
2021-03-23 14:00 BST · 19 hours, 25 minutes, 6 seconds

Updates

Resolved

The issue has been resolved.

March 24, 2021 · 09:25 BST
Issue

Telcoswitch users currently unable to make Outbound calls. Inbound calls are still coming through.

March 23, 2021 · 14:00 BST

← Back