Inbound and Outbound Calling

Major incident VoIP Telephony
2026-06-24 16:36 BST · 22 minutes

Updates

Resolved

All services are now running as expected and we are monitoring the results.

June 24, 2026 · 16:58 BST
Update

The issue has been identified and a fix is being implemented.

June 24, 2026 · 16:37 BST
Issue

We’re investigating reports of dashboards failing to load and inbound and outbound not working.

June 24, 2026 · 16:28 BST

← Back