Google Outage

Major incident Google Workspace
2020-12-14 12:33 BST · 53 minutes, 34 seconds

Updates

Resolved

This incident has been resolved.

December 14, 2020 · 13:26 BST
Update

Around 20 minutes ago services started to come back alive and people are able to access their google services. Updates to follow.

December 14, 2020 · 13:16 BST
Issue

Currently the google service is down. This appears to be europe wide. Further updates to follow.

December 14, 2020 · 12:35 BST

← Back