Issues with outbound calling

Minor incident VoIP Telephony
2026-05-14 11:19 BST · 31 minutes

Updates

Resolved

Resolved - This incident has been resolved.

May 14, 2026 · 11:49 BST
Monitoring

Monitoring - A fix has been implemented and we are monitoring the results.

May 14, 2026 · 11:20 BST
Issue

Identified - We have identified an issue with outbound calls connecting and are working on a fix. We will provide another update within 10 minutes.

May 14, 2026 · 11:19 BST

← Back