Degraded Performance

Minor incident Telephony
2026-01-13 13:02 GMT · 20 hours, 14 minutes

Updates

Resolved

This incident has been resolved.

January 14, 2026 · 09:14 GMT
Resolved

This incident has been resolved.

January 14, 2026 · 09:00 GMT
Investigating

Monitoring - A fix has been implemented, and we are monitoring the results.

January 13, 2026 · 13:03 GMT
Issue

We have had reports regarding a similar issue that was occurring yesterday.

January 13, 2026 · 13:02 GMT

← Back