Internet Outage

Major incident Leased Line Internet Connections ADSL/FTTC/ SoGEA / FTTP Internet Connections
2025-10-29 10:20 GMT · 6 hours, 39 minutes

Updates

Update

The majority of the VoIP platform is back up and running, and we are seeing a lot of broadband and ethernet circuits having returned too. But the services should still be considered at risk until we have confirmation that the issue is fully resolved.

October 29, 2025 · 12:22 GMT
Investigating

The issue is affecting the VoIP platform as well as DSL and ethernet circuits. We apologise for this issue, it’s being urgently investigated. We are seeing some services returning but many are still down.

October 29, 2025 · 10:44 GMT
Issue

We are investigating an outage affecting broadband and leased line circuits terminating in the LD8 (Hex) data centre. This started around 10:00. Apologies for the disruption caused. Once we have more details to share we will be in touch.

October 29, 2025 · 10:20 GMT

← Back