VOIP - INBOUND & OUTBOUND CALLS

Major incident Telephony
2025-10-20 10:50 BST · 1 day, 25 minutes

Updates

Resolved

We have monitored this throughout the day and can see services has been restored as normal.

October 20, 2025 · 17:00 BST
De-escalate

We have seen areas on AWS return to normal service. We will continue to track this throughout the day.

We greatly appreciate your patience and understanding during this time

October 20, 2025 · 11:57 BST
Update

Our team are aware of issues with AWS affecting some services this morning which are having a knock-on effect to our VOIP platform.

Our provider continues to investigate the issue however our mitigation steps have been successful and we’re seeing services restored to across affected zone. Next update in 20 minutes.

https://www.bbc.co.uk/news/live/c5y8k7k6v1rt

October 20, 2025 · 11:22 BST
Investigating

We have received an influx of reports about users’ VOIP phones not being able to dial outbound and inbound.

We are currently investigating the issue and will update the status page when we have more information.

October 20, 2025 · 10:50 BST

← Back