VOIP - INBOUND & OUTBOUND CALLS

Major incident Telephony
2025-07-25 10:17 BST · 53 minutes

Updates

Resolved

The cause appears to be a bug with a third party aspect of our
platform with a memory handling issue.

Systems should now be operational. If you are having trouble with your phone, please reboot it first and then call us.

July 25, 2025 · 11:09 BST
Issue

We have received a number of reports that inbound and outbound calls are not working this morning.

If you call a number and you do not get a dial tone, you are one of the customers affected.

Our provider is working on a fix currently, and it should be resolved within the hour.

Further update to follow shortly.

July 25, 2025 · 10:17 BST

← Back