Post Dial Delay

Major incident Telephony
2025-07-09 11:48 BST · 2 days, 11 minutes

Updates

Monitoring

A fix has been implemented and we are monitoring the situation

July 9, 2025 · 14:28 BST
Investigating

We’re investigating further reports of similar issues and will provide a further update shortly.

July 9, 2025 · 13:56 BST
Issue

Several users have reported an ongoing issue with calls struggling to connect inbound and outbound.

It is possibly a partial platform outage as we haven’t been able to get in contact with our upstream provider.

We will try to have this resolved ASAP apologies for the inconvenience.

July 9, 2025 · 11:48 BST

← Back