VOIP Outage
Major incident
Telephony
2024-09-10 14:52 BST
· 1 hour, 24 minutes
Updates
Resolved
September 10, 2024 · 16:16 BST
Issue has been resolved by our upstream provider.
We are sorry for the inconvenience caused.
Issue
September 10, 2024 · 14:52 BST
We have been aware that users are experiencing issues with outbound and inbound calling.
The issue is being investigated and we will update this page within the next 15 minutes.
← Back