Outbound Calls

Major incident Telephony
2024-08-12 12:34 BST · 2 hours, 3 minutes

Updates

Resolved

This issue was classed as resolved

August 12, 2024 · 14:37 BST
Issue

We are aware of an issue which is affecting outbound and possibly inbound calls at the moment.

If you are trying to reach us and can’t get through, please email [email protected]

August 12, 2024 · 12:34 BST

← Back