Internet Outage
Minor incident
Leased Line Internet Connections
ADSL/FTTC/ SoGEA / FTTP Internet Connections
2024-02-27 13:14 GMT
· 19 hours, 51 minutes
Updates
Investigating
February 28, 2024 · 09:04 GMT
We believe this issue to now be resolved.
If you are still experiencing internet connectivity issues, please contact our support team on 01273359133 or email [email protected].
Update
February 27, 2024 · 13:34 GMT
We are seeing the bulk of affected broadband sessions restored. If you are still impacted please reboot the router as a first step.
The cause of the unexpected drop remains under investigation. We will share more details once understood.
Apologies for the disruption caused.
Investigating
February 27, 2024 · 13:14 GMT
We are aware of a drop impacting BT Wholesale connections. This is under investigation and we will share more details once understood.
← Back