Callswitch App for IPhone

Minor incident Telephony
2023-10-23 12:00 BST · 1 day, 21 hours, 30 minutes

Updates

Resolved

The issue should now be resolved, and full service on the iOS app has been restored. There is no need to restart or refresh the app on the relevant devices.

We continue to to work with the third parties involved with the issue to further understand it’s cause and remove the risk of reoccurance going forward.

October 25, 2023 · 09:27 BST
Issue

There is currently an ongoing issue that is affecting inbound calls on the callswitch app for IPhone.

This is not affected on Android phones nor the Callswitch App for Laptops or PC’s

It has been raised with our upstream provider and they are actively investigating it.

October 24, 2023 · 10:18 BST

← Back