Inbound call issue

Minor incident Telephony
2023-03-06 11:08 BST · 2 hours, 23 minutes, 1 second

Updates

Resolved

Testing indicates that the issue is fully resolved. Please email [email protected] if you have further problems. Many thanks

March 6, 2023 · 13:31 BST
De-escalate

We believe the issue to be resolved and incoming calls are now arriving as expected

March 6, 2023 · 12:35 BST
Update

We continue to investigate the issue and will provide more conclusive information as we have it. At this stage, we aren’t seeing calls terminate into our network from our upstream numbering partner. We are working with them to resolve the issue and will update again in 15 minutes.

March 6, 2023 · 11:32 BST
Issue

We are aware of an incident impacting inbound calls. We are investigating and will provide a further update in 15 mins.

March 6, 2023 · 11:08 BST

← Back